GCP regional quota error
- GCP insufficient regional quota SSD
- GCP disk type pd-standard vs pd-ssd
- GCP nodepool disk type terraform
- GCP SSD quota limit trial account
Suppose you are faced with the error:
Error: error creating NodePool: googleapi: Error 403: Insufficient regional quota to satisfy request: resource "SSD_TOTAL_GB": request requires '700.0' and is short '200.0'. project has a quota of '500.0' with '500.0' available.
The reason is that GCP has a standard limit for SSDs within a region. You can try to increase it, but keep in mind that some quotas can’t be increased within the trial 300$ account or can be increased only after upgrading to a paid account and even making a support request.
The thing is that there are a number of disk types: https://cloud.google.com/compute/docs/disks.
The most interesting ones for us are pd-ssd and pd-standard.
GCP set pd-standard disk type by default some time ago. And if you have some scripts or Terraform configurations for your cluster, they created machines with pd-standard disk type back then.
At some point in time, GCP switched to the pd-ssd disk type by default, and your scripts started working the other way, and you unexpectedly faced a quota limit.
Thus, the solution is to specify the disk type explicitly in your Terraform code. GKE example:
resource "google_container_node_pool" "node_pool" {
// ...
node_config {
machine_type = …
disk_type = "pd-standard"
}
}